Setting up OLPC on an Intel MacBook Pro

From Stack Overflow
Jump to: navigation, search

Setting Up Emulated Environment

This section details how I set up the OLPC image on my MacBook Pro. This was done to properly try out the environment, in hopes of writing applications.

The following DID NOT work. Skip it.

  • Noted this page:
  • Decided Ubuntu (or Kubuntu, as the case may be for me) Gutsy Gibbon was the way to go because a single repository could be added to automatically pull the latest Sugar/OLPC environment.
  • Discovered that Parallels dislikes the current Kubuntu 7.10 (Gutsy) beta
  • Downloaded VMWare Fusion trial
  • Initially took forever to get to the installer, but upped the VM memory to 768MB
  • Now, consistently gets "stuck" at "87%: Installing Language Packs" in the installer. It's not truly stuck (or is it?) It's using a lot of CPU, so it's not hung, but may be in a loop or something. Several hours later, still no progress.

After this, decided to try a different route.

The following DID work.

  • Downloaded latest OLPC disk image from (as of this writing it's
  • Used Parallels Transporter to convert it from a VMWare image to a Parallels image
  • Parallels will only convert the HDD, not the VM itself. It also says it is not a bootable image, but it lies. Also: remove dashes from both folder name and filename (Parallels doesn't seem to like them?)
  • Create new Parallels VM using advanced/custom, set memory to 128MB, point it to your converted image
  • In the final step, uncheck the "install Linux" checkbox. (Remember, Parallels doesn't think the image is bootable, but it is.)
  • Start up the VM. You should get the boot loader (GRUB?), some text-mode boot information, then the login screen. At this point, you're golden. Have fun!

After booting, the network isn't up. This fixed it:

  • Ctrl-Alt-Fn-F2 to get to a console/login window
  • Log in as root (no password)
  • I couldn't get dhcpd to work, so I manually used ifconfig (ifconfig eth0 netmask, route (route add default gw, and /etc/resolv.conf (copying the two nameserver entries from my OS X /etc/resolv.conf into the OLPC's /etc/resolv.conf)
  • exit the shell
  • ctrl-alt-fn-F3 to return to OLPC GUI

Writing Code

...still learning this...

OS X Build Environment

...figuring this out...

...didn't work... Kubuntu Feisty under Parallels: